
The File Menu

"New"
Design Mode

The "New" command will erase all information in the current database and let you start a 
new database on a blank ViaBase Template...

If the database in memory has not been saved since you last changed it, you'll be 
prompted as to whether you wish to save it before the "New" command is executed.

"New Using Current Template"
Design Mode

The "New Using Current Template" command will erase all information in the current 
database BUT keeps the current    ViaBase Template intact.    You'll begin again at one blank
record.

If the database in memory has not been saved since you last changed it, you'll be 
prompted as to whether you wish to save it before the "New    Using Current Template" 
command is executed.

"Open ViaBase"
Design Mode or Database Mode

Use this command to "Open" an existing ViaBase database and load it into memory.

If the database currently in memory has not been saved since you last changed it, you'll 
be prompted as to whether you wish to save it before the "Open" command is executed.

"Save ViaBase"



Design Mode or Database Mode

If the file has not been previously saved when you select this command, a File Window will 
appear.    Locate the directory where you wish to save the file, enter a new file name, a 
description of the file in the box on the right of the File Window, and press the "Okay" 
Button.

If the file has been saved previously, selecting this command will update the file on disk.

ViaBase Database are saved in two files, one with the extension .VBF, the other with 
a .VBV extension.    The Records themselves are saved in the .VBF file while the other 
contains Template information.

IMPORTANT:    ViaBase Records are edited in memory and you MUST SAVE them to disk 
before exiting ViaBase or your changes will be lost.    It is ALWAYS a good idea to save your 
work periodically, and make REGULAR backups of your databases.

"Save ViaBase File As"
Design Mode or Database Mode

When you select this command, a File Window will appear.    Locate the directory where 
you wish to save the file, enter a NEW file name,    a description of the file in the box on the
right of the File Window, and press the "Okay" Button.

If there is a Query in effect, you'll be offered the option of ONLY saving the records that 
match the Query Record.    Click on the Check Box in the bottom-right of the File Window 
that says "Save Query Records Only".

"Import Ascii File"
Design Mode or Database Mode

This option allows you to use an existing database in ViaBase.    The existing database 
must exist in a file on disk with a .TXT extension, and it must be in Comma-Delimited 
Ascii... format

When you specify a .TXT file to Import, ViaBase will clear the Template an enter Design 
Mode..., load in all the records, and create Field Objects... for each field.    The Field Objects
will be stacked on top of one another so you'll need to drag them into place.    Then 
continue designing your new ViaBase!

If the database currently in memory has not been saved since you last changed it, you'll 
be prompted as to whether you wish to save it before the "Import" command is executed.

"Export As Ascii"
Design Mode or Database Mode

See "Exporting Your Database As Text..." for detailed information on this command.

"Print Screen Records"
Database Mode



The "Print Screen Records" command causes an exact copy of the record on your screen 
(Template and all) to be printed to the printer.

When you select this command, the Print Configuration Window will pop up.    Configure 
the printout as you want it to be (Number of Copies, Print All or Queried Records, etc...) 
and click the "Okay" Button.

For real power in printing your database, use ViaPrint Ultra...

"Exit"

Exits ViaBase.



Keyboard Controls
A mouse is required in ViaBase, however the keyboard will make some operations easier.

In Database Mode:

[Ctrl] + [Right Arrow] - Show next Record
[Ctrl] + [Left Arrow] - Show Previous Record
[Ctrl] + [Down Arrow] - Jump Forward 15 Records
[Ctrl] + [Up Arrow] - Jump backward 15 Records
[Ctrl] + [End] - Go to Last Record
[Ctrl] + [Home] - Go to first Record

To display this Help File in either mode press F1.



In Design Mode your Record Template can be edited to look like you want it to.    You also 
set Field Types... in this mode.. The Lock Control... toggles between the two ViaBase 
Modes, Design Mode and Database Mode.    



In Database Mode your Record Template becomes your database record entry Window.    
The Lock Control... toggles between the two ViaBase Modes, Design Mode and Database 
Mode.    



The Edit Box (Design Mode Only) is where you enter the text that will be displayed on your 
Template in Label Objects and Field Objects.    As you type in the Edit Box your text is also 
displayed in the current Object using the type of Font and Font Style you specify in the Text
Menu...



The Lock Control is on the Viabase Toolbar... and has a picture of a KEY on it. Use it to 
"Lock" ViaBase into Database Mode so you can edit Records, or to "Unlock" ViaBase into 
Design Mode so you can add Objects or change their settings.    You can also use the "Lock 
Design" command from the Edit Menu...



The Toolbar
As you change Modes in ViaBase the Toolbar also changes.

The Toolbar In DESIGN MODE:

In ViaBase Design Mode... the Toolbar Consists of the following Tools:

The Design Mode Edit Box... is used for entering Prompt and Label Object Text.

The Lock Control... "locks" ViaBase into Database Mode so you can add/edit Records.

Open a ViaBase File.

Save the current ViaBase File

Add a Field Object... to the Template...

Add a Label Object... to the Template.

Add a Picture Object... to the Template.

Select a Font and Font Size for the current Object.

Make Object text Bold, Italic, or Underline.



Center the current Object on the Template.

Snap Objects to the Grid for design.

The Toolbar In DATABASE MODE:

In ViaBase Database Mode... the Toolbar Consists of:

The Browse Scroll Bar... advances through your ViaBase Records.

The Lock Control... "UNlocks" ViaBase back into Design Mode so you can add/edit your 
Design Objects or Field Settings..

Open a ViaBase File.

Save the current ViaBase File

Add a RECORD to the database.

Edit the Query... Record.

Display the Query History Window...

Cancel current Query.

Search the Database.

Sort Records.





Introduction To ViaBase
Two Modes:    "Design" and "Database"
The ViaBase Window in Design Mode

 Here is where you design your ViaBase Record Template.    In Design Mode... the Edit Box 
and the Design Mode Toolbar are visible.    The text you enter in the Edit Box is displayed in
the selected Design Object if that object allows text.    A ViaBase Window with a sample 
Template is shown below:

                                    Edit Box...                                                                            Design Mode Toolbar....

      Design Objects... in Design Mode

When your Record Template design is complete, you will "LOCK" the design into Database 
Mode using the Lock Control... on the Toolbar, or by selecting "Lock Design" from the Edit 
Menu... 

The ViaBase Window in Database Mode

Once the design is LOCKED, ViaBase goes into "Database Mode" and you begin editing 
your Records...    The Edit Box is replaced by the Browse Scroll Bar and the Toolbar changes
to database tools.

                                  Browse Scroll Bar...                                                      Database Mode Toolbar....



      Design Objects... in Database Mode

The ViaBase Window: A Workspace For Database Creation

The ViaBase Window is divided into three areas:    The Menu Bar, The Toolbar, and the 
Template Workspace.    You'll build your Record Templates on the Workspace by adding 
Design and Field Objects, assigning them colors, and dragging them to where you want 
them on the Template.

When your database Template is complete, you click on the Lock Control... and start 
editing your Records!

ViaBase Bounds

The following lists the limits on elements within ViaBase:

1) Records are limited to 32,000 characters.

2) In the current version there are limitations on field types.    You can have a total of 50 
Field Objects...    Individual Field objects are limited to:

A) 50 Character, Date, or Formula Field Objects.
B) 15 Numeric Field Objects.
C) 10 List or Data List Field Objects.
D) 3 Note Field Objectw.
E) 1 Picture Field Object.

3.    Note Field Objects can contain up to 5,000 characters (which are part of the total 
Record capacity of 32,000).

4.    Limitations on Design Objects...:

A) 50 Field Objects.
B) 10 Label Objects.
C) 10 Box Objects.
D) 6 Picture Objects.



5.    Number of Records:    Available memory.    ViaBase stores records in memory very 
efficiently.    But up around 5,000 or so records things like queries, sorts, and searches start
getting rather slow. Future versions will deal with this speed problem.



Contents...
Ordering/Registration Information

Glossary of ViaBase Terms
The ViaBase Menu Bar And Controls

ViaPrint Ultra!

Read These First...

1. Introduction:    The Design Workspace And The ViaBase Modes
2. ViaBase Template Design Objects

3. ViaBase Field Types

Procedures

A Step-By-Step Walkthrough - Creating A ViaBase Database
Editing The Query Record
The Query History Window
Using Formula Field Objects
Adding To List Field Objects

Setting Field Type, Name, And Order
Exporting Ascii Database Files

Warranty And Licensing



The ViaBase Menu Bar
Summaries of the functions of the ViaBase Menu Bar and Toolbar.

           "File"    Menu  
           "Edit"    Menu  
           "View"    Menu  
           "Design"    Menu  
           "Field"    Menu  
           "Text"    Menu  

           The ViaBase Toolbar  



The Edit Menu:

"Undo Field Change"
Database Mode

This option will restore the contents of the Field Object that currently holds the cursor.    
Once the cursor leaves the Field Object, however, the original contents are lost.

"Undo Record Change"
Database Mode

This option restores the original contents of the current Record prior to any editing you 
may have done.    

"Preferences"
Design Mode or Database Mode

Displays the ViaBase Preferences Window.    Here you can enter a default Font that ViaBase
will use in Design Mode.    You can also enter the Path leading to the directory you wish to 
save your ViaBase files to.

"Lock Design"
Design Mode or Database Mode



Use this option    to "Lock" ViaBase into Database Mode... so you can edit Records.

Also use this option "Unlock" ViaBase back into Design Mode... so you can add Objects or 
change their settings.    

This menu option is "checked" when ViaBase is in Database Mode.

"Copy Record"
Database Mode

Selecting this option will cause the current Record to be copied into the Windows 
Clipboard.

"Paste"
Database Mode

If there is a valid ViaBase Record in the Windows Clipboard, selecting this option will cause 
that Record to replace the current Record.    A confirmation window will appear since the 
paste operation will overwrite the current Record.

"Search"
Database Mode

ViaBase's Search function allows you to search ALL fields or just one field in each Record.    
Enter the text you want to search for in the Search Window and click on the "Search" 
Button.    When a match is found the matching Record is displayed and the Field Object 
containing the match is highlighted.    

To continue the Search continue pressing the "Search" Button until it is complete. To stop 
the Search before it's complete, click on the "Cancel" Button.

"Search And Replace", "Re-Calculate..."
Database Mode

This function allows you to search for data in fields and change it.    You can confirm each 
change or select the "Replace All" option.    Be careful using this function!

After using "Search And Replace", or after changing the formula in a Formula Field..., be 
sure to select the "Re-Calculate Formula Fields" option.    This will update all formulas with 
the new information.    See also: Using Formula Fields...

"Sort Records"
Database Mode

The Quick Sum function is a handy tool for reporting TOTALS for values in Field Objects 
across Records.    A Step-By-Step for acquiring a Quick Sum:

1. Select this option from the Edit Menu.



2. In the Quick Sum Window that appears, select up to three Field Object Names that
you would like totals for.    (The fields must contain valid numeric values or a value of zero 
will be added to the Quick Sum for that field)

3. Click on the "Okay" Button on the Quick Sum Window.

All Records will be searched (or all Queried Records if a Query is in effect) and the values 
in the selected fields will be added together.

At that point the Quick Sum Window will reappear with each total displayed in the format 
of each selected Field Object.

"Insert Date"
Database Mode

This option will cause the current System Date to be inserted into the current Field Object 
(the one where the cursor is).

"Add/Change Picture Or Sound"
Database Mode

Selecting this option will cause a File Window to appear where you can assign a picture or 
a sound to a Picture Field Object.    See also: "Field Types..."

"Copy Picture To Windows Clipboard"
Database Mode

If you have a Picture Field Object in the current record this command will cause the picture 
to be copied into the Windows Clipboard for pasting into other Windows Applications. 

"Add Record"
Database Mode

Selecting this option will cause a blank Record to be added to the end of your database, 
ready for editing.

"Delete Record"
Database Mode

This option will DELETE the current Record from your database.    A confirmation window 
will appear to make sure this is what you want to do!

"Sort Records"
Database Mode

You can select three fields to SORT your Records by in the window that appears when you 
select this option.    ViaBase will sort your records in Ascending or Descending order.



For sorting by Numeric or Date Field Types, be sure to select the Numeric/Date Sort.    Also 
use the Numeric/Date Sort if you want the sorting process to ignore character case.

NOTE:    If a Query is in effect, only the Query Records are sorted.    Clearing the Query 
restores the original order of the Records.



The View Menu

"Edit The Query Record"
Database Mode

This option causes the Query Record... to be displayed.

"Apply Query"
Database Mode

Within the Query Record, and with Simple or Conditional Query criteria set, this option 
causes the Query process to begin.

See also: "Query Record..."

"Edit Query Field Conditions"
Database Mode

Within the Query Record this option displays the Field Conditions Window.

See also: "Query Record..."

"Query History"
Database Mode

This option allows you to view the current Query History.

See also: "Query History Window..." 

"Clear Current Query"
Database Mode



Within the Query Record this option clears all Field Objects of Query criteria.

See also: "Query Record..."

"Exit Query Record"
Database Mode

When selected within the Query Record, this option returns you to your database Records.  

See also: "Query Record..."

"View Picture Field"
Database Mode

If your database Record contains a Picture Field Object, selecting this option will cause the 
picture to be displayed in a full screen Window in its original size.

"Play Sound Or Midi"
Database Mode

If you have a Picture Field Object in the current Record that has a sound assigned to it, this
option will play that sound.

See Picture Field Object under Field Types... for more information

"Stop Playing Midi"
Database Mode

Stops the play of a Midi File.



The Design Menu:

"Add Picture"
Design Mode

This option allows you to add a Picture Object... to your ViaBase Record Template.    A File 
Menu will appear from which you can locate the picture file you wish to add (either 
Windows Metafile or a Bitmap file).    When you've highlighted the file name, click on the 
File Window's "Okay" Button.

Your Picture Object will now appear on the Template.    Position and resize it as you wish.

See also: Design Objects...

"Add Label"
Design Mode

Clicking on this option will add a Label Object... to your Template.    Type the text for the 
new Label in the Edit Box...    Then use the options in the Text Menu... to set the Label 
Object Font and Font Style to the way you want it.

See also: Design Objects...

"Draw Box"
Design Mode

In order to draw a Box Object... on your ViaBase Record Template:

1. Place the mouse cursor over the point on your Template where you want the 
upper left-hand corner of the box to be.



2. Press the left mouse button and, while holding it down, move the mouse cursor 
down and to the right.

3. A "rubber band" box will be drawn as you pull the mouse cursor.    When the box is
the size you want, RELEASE the left mouse button. 

4.    Finally, select this option from the Design Menu and your Box Object will appear. 
You can move and resize it as you wish.

See also: Design Objects...; Moving A Group Of Objects...

"Label, Picture, And Prompt Color"
Design Mode

Selecting this option will allow you to change the color of the text displayed in Label 
Objects, the Prompt part of Field Objects, or the background color of Picture Objects that 
contain Windows Metafiles.

This option will also change the background color of Box Objects...

"Background Screen"
Design Mode

Use this option to change the color of the ViaBase Template.

"Field Foreground"
Design Mode

Allows you to change the color of the text displayed in the currently selected Field Object.

"Field Background"
Design Mode

Allows you to change the background of the currently selected Field Object.

"Center"
Design Mode

Selecting this option will cause the currently selected Design Object to be centered on the 
ViaBase Template.

"To Front"
Design Mode

This option works only on Label Objects and Box Objects.    It will cause the current object 
to be displayed in FRONT of all other objects of its type.



"To Back"
Design Mode

This option works only on Label Objects and Box Objects.    It will cause the current object 
to be displayed BEHIND all other objects of its type.

"Snap To Grid"
Design Mode

When this option is "checked", all objects will align themselves to the ViaBase grid when 
they are moved or clicked on.    This is helpful for lining objects up on your Template.

"Change Grid Size"
Design Mode

Allows you to specify the size of the ViaBase grid.



The Field Menu

"Add Field"
Design Mode

Choose this option to add a Field Object...    You can add up to 50 Field Objects in ViaBase.

"Field Settings"
Design Mode

This option brings up the Field Description Window where you set the Field Type for a Field 
Object, as well as enter its Tab Order and Name.

See also: "Object Types..."; "Field Description Window..."

"Field Format"
Design Mode

If the Field Type of the currently selected Field Object is a formattable type, ie. Numeric, 
Date, Picture, or Formula, a second menu will appear with the Formats available for that 
Field Type. Click on the format you want your Field Object displayed in.

The format will take effect when ViaBase is in Database Mode...

"Delete Field"
Design Mode

Selecting this option will cause the currently selected Field Object to be deleted.    
WARNING: Any information that the field contains in existing Records will ALSO be deleted!



The Text Menu

"Fonts"
Design Mode

This option brings up the Font Window, where you can select the Font Name, size, and 
style that the text in the currently selected Field Object... or Label Object... will be 
displayed in. 

"Bold"
Design Mode

Sets the Font Style of the currently selected Field Object or Label Object to "bold".

"Italic"
Design Mode

Sets the Font Style of the currently selected Field Object or Label Object to "italic".

"Underline"
Design Mode

Sets the Font Style of the currently selected Field Object or Label Object to "underline".

"Normal"
Design Mode

Sets the Font Style of the currently selected Field Object or Label Object to "normal", 
removing any bold, italic, or underline styling.



Types Of Fields Available In ViaBase
[Field Types Are Set In DESIGN MODE]

Each Field Object... in ViaBase can be assigned a Field Type which determines how that 
Field Object will behave in Database Mode... You set the Field Type from Field Description 
Window...    This window is accessable in Design Mode by double-clicking on the Prompt 
part of the Field Object - or by selecting "Field Settings" from the Field Menu...

An Explanation of each Field Object Type, and how that Field Object is displayed in 
Database Mode, follows:

CHARACTER FIELD

In Database Mode Character Field Objects display the Field text as you type it.    

Character Field Object widths are expandable.    Even so, if you type beyond the width of 
the Field Object on the screen, the text you see just scrolls to the left.    The text you can't 
see is still saved in the Record.

When you add a field in Design Mode it is automatically set to the Character Type.

NUMERIC FIELD

Numeric Field Objects display text as right-justified NUMBERS in Database Mode.    In 
Design Mode you can format the Field Object to display numbers in five different formats: 
Currency, Fixed, Leading Zeros, Commas, or Incremental.    See "Field Format" under the 
Field Menu... for more information on formatting Field Objects.

Numeric Field Object widths are expandable. Fifteen Numeric Fields are available in each 
ViaBase Template you design.

LIST FIELD

List Field Objects are displayed in Database Mode as drop-down list boxes. You add to the 
list by using the "Add" Button displayed next to the Field Object.

The list you create for each List Field Object is available in each Record.    List Field Objects 
are useful when the contents of the database field will be limited to certain choices.

For example, if you are creating an invoice Template and one of the fields you need will be 
for "Payment Type", you might add the following list items to your List Field Object:

Cash
Check
COD
Credit Card
Money Order



When you enter the data for each Record, just select the item from the list that applies to 
that Record.

List Field Object widths are expandable. List Items are sorted alphabetically in List Field 
Objects.    Ten List Field Objects are available for your Template.    See also: "Add To Field 
List" Window...

DATE FIELD

Date Field Objects display date information in Database Mode.    You can format how you 
want a date displayed using the "Format Field" option from the Field Menu...    The formats 
available are as follows:

01/01/95
01/01/1995
January 1, 1995
January 1
January 1995

Date Field Object widths are expandable. Dates MUST be kept in Date Field Objects in 
order for the ViaBase Query... to utilize them.

NOTE FIELD

Note Field Objects are used for freeform data entry in your database.    In Database Mode a
Note Field Object is displayed as an inch high text box with a scroll bar on the right side.

Note Field Object widths are expandable. You can enter up to 5,000 characters in a single 
Note Field Object.      Three Note Field Objects are allowed per Template.

PICTURE FIELD

In Database Mode a Picture Field Object displays the Bitmap or Metafile picture you specify.
To choose a picture, DOUBLE-CLICK on the picture itself (or, if no picture has yet been 
selected, the little white box next the Prompt) and a File Window will appear.    Select the 
File Type, .WMF or .BMP, then click on "Okay" when you've located the picture file name 
you want.

You can also assign a SOUND to a Picture Field Object in the same way.    From the File 
Window select File Type .MID (Midi Files) or .WAV (Windows Wave files) and click on "Okay" 
when you've located the sound file you want. To play the sound in Database Mode, just 
click once on the Picture Field Object with the left mouse button.    If you want to STOP 
playing a Midi file, click on the Object with the RIGHT mouse button.

You can format the size that the picture is displayed in by using the "Field Format" option 
of the Field Menu...    Only one Picture Field Object can be placed on a Template.

FORMULA FIELD



Formula Field Objects are explained in detail under Using Formula Fields...

In Design Mode you can format the Formula Field Object to display numbers in four 
different formats: Currency, Fixed, Leading Zeros, or Commas.    See "Field Format" under 
the Field Menu... for more information on formatting Field Objects.

Formula Field Object widths are expandable. 

DATA LIST FIELD

Data List Field Objects are displayed in Database Mode as drop-down list boxes, much like 
List Field Objects. You add to the list by using the "Add" Button displayed next to the 
Object.

The list you create for each DATA List Field Object is SPECIFIC to each Record, however.    
Data List Field Objects are useful for lists that belong with a particular Record.

For example, if you are creating a telephone contact    Template and one of the fields you 
need will be for "Contact History", you might add the following list to your Data List Field 
Object as time goes on:

2/4/95    Discussed dropping sales.
2/6/95    Made luncheon appointment for 2/7/95
2/7/95    Discussed dropping sales over lunch.
2/10/95    Discussed amazing turnaround in sales!
Etc...

Data List Field Object widths are expandable. See also "Add To Field List" Window...



Template Design Objects
[Design Objects Are Available In DESIGN MODE]

There are four types of Template Design Objects available in Viabase DESIGN Mode...: The 
Field Object, the Label Object, the Picture Object, and the Box Object.    To help explain 
these Objects, take a look at the following example Template:

Field Objects:

Field Objects consist of two parts, the Prompt and the Field box. The Prompt part is the part
you "drag" to move a Field Object.      You place Field Objects where you want the actual 
Fields to appear in Database Mode. Then you select theType of Field you want and its 
format.    See Field Menu... for more on this.

Label Objects:

Labels are used to indicate any static information on the Template.    You can change the 
font, font style, font size, and text color to suit your needs.    In the example above the 
words "Marty's Friends" are contained in a Label Object. Up to 10 Label Objects are 
allowed on a Template.    See:    Design Menu... "Add Label" Command for more information.

Picture Objects:

In the above example, the picture of Marty is a Picture Object.    Picture Objects can contain
Bitmap style graphics or Windows Metafile graphics.    Picture OBJECTS are different from 
Picture FIELDS - they are for design purposes only and do not change with each record.      6
Picture Objects are allowed per Template.    See:    Design Menu... "Add Picture" Command...
for more info on creating Picture Objects.



Box Objects:

The grey box surrounding the other Objects above is a Box Object.    These are useful for 
grouping Fields and other information - or for just plain fancying up your Template.    See 
also: Design Menu... "Draw Box" Command... 



Glossary of ViaBase Terms
Box Object... Lock Control...
Browse Scroll Bar... Menus...
Character Field... Note Field...
Comma-Delimited Ascii... Numeric Field...
Database... Picture Field...
Data List Field... Picture Object...
Date Field... Query...
Design Objects... Record...
Edit Box... Template...
Field... Toolbar...
Field Object... Workspace...
Field Prompt...
Formula Field...
Label Object...
List Field...



The Template Workspace is the area of the ViaBase Window where your Template is built.    
When ViaBase is first run the Workspace is GREY, and takes up the lower nine-tenths or so 
of the window (depending on your screen resolution).



The Template is what you create on your ViaBase Workspace    that will allow you to add to 
and edit your database records.    You'll create the necessary Field Objects and position 
them, then add Design Objects to organize or improve the looks of your Template.



A "Database" is simply a list of repetitive information.    Your telephone book is a database 
of names, businesses, their addresses and phone numbers.    ViaBase lets you create 
databases to store the information YOU need.    You can then print the information, search 
it, perform a ".Query." on it, and more!



A Record is made up of one or more Fields... in your Database...    If you think of your 
telephone book:    The listed person's name is a Field.    Their address is another Field, and 
their telephone number is yet another.    These three pieces of information, Fields, together
constitute a Telephone book RECORD.    In ViaBase you'll create a Template for editing your
own records.    A record in Viabase can contain up to 50 fields of informaiton.



Setting Field Type Descriptions
[Field Types Are Set In DESIGN MODE]

The "Field Description" Window

To set the Field Type for your Field Object... you DOUBLE-CLICK on the Prompt part.    
Alternatively, after clicking once on the Prompt to highlight the Field Object, select "Field 
Settings" from the Field Menu...

Either action will bring up the Field Description Window:

In the Field Description Window you'll enter three important pieces of information about 
what you want your Field Object to be in Database Mode...

Entering A NAME For The Field Object

In the "Name" text box at the top of the window you may want to give the Field Object a 
meaningful name.    Field Objects are given names by ViaBase (Field1, Field2, etc...), but 
meaningful names that describe what the Field is meant to hold will make your querying, 
etc. much easier.

Field Object names can be up to twenty characters long, but they can NOT include spaces 
or puncuation.    You can use the underscore character in them, however.    Some examples 
of valid Field Object names:

Last_Name
ZipCode
COUNTRY



The name you choose will be used in Formula Fields and in printouts, so using meanful 
names - especially on larger databases - is a good idea.

Changing The TAB ORDER Of Your Field Objects

In Database Mode when you are actually editing your Records, you'll use the TAB key on 
your keyboard to move the cursor from one Field Object to the next.    The order in which 
the cursor reach Field Objects is adjustable in ViaBase, no matter what order the Field 
Objects themselves were created in.

Assign the Field Object you wish to edit first a Tab Order of "1", the second "2", the third 
"3", and so on.

NOTE:    The formulas specified in Formula Fields... are calculated ACCORDING TO THE TAB 
ORDER.    Be sure to keep this in mind when you enter your formulas!

Selecting The Field Type For A Field Object

Click on the name of the Field Type to make the selected Field Object that type.    If you are
changing a Field Object from one type to another, you may get a little confirmation 
window.    Changing the Field Type of a List Field Object for example will result in the 
deletion of the list for that Object.

When you've named your Field Object, set its Tab Order (if necessary), and assigned it a 
Field Type, press "Okay" on this window and you're done.

Formula Settings

If you selected the Field Type "Formula", the above controls will become visible on the Field
Description Window.    For more information on these, see Using Formula Fields...

See Field Types... for a detailed description of the different Field Object Types available.



Using Formula Fields
[Formulas Are Created In DESIGN MODE]

Formulas are entered in the Field Description Window... using these controls:

Pressing each of the buttons shown above will add that particular symbol or Field Name to 
the formula text.    The "Clear" Button will clear the entire box, erasing the current 
formula(s).

Formula Field Objects display the RESULTS of the formula entered in the Window shown 
above for the particular Formula Field Object that is selected.

When entering a formula there are a few rules to remember:

1) At least one space character must separate the elements of a formula.
2) Alphanumeric character "strings" (like "Smith" as shown above) MUST be 

enclosed within double quote marks.    This does not include numeric values or dates.
3) Field Object Names MUST be enclosed within brackets, as <<LastName>> in the 

above window is.
4) Only those symbols shown on the control buttons at the top of the window (+, -, 

x, /, =, <, >, And, Or) have any meaning to ViaBase.    Any other symbol that is not 
contained within double quote marks will cause an error.

The Operators used in formulas:

(+) - Addition
(-) - Subtraction
(x) - Multiplication
(/) - Division
(=) - Equals
(<) - Less Than
(>) - Greater Than

Simple Formulas

The SIMPLE Formula consists of a mathmatical phrase like:

<<Total>> x <<TaxPercentage>>

Assuming that (in Database Mode..., of course) <<Total>> is the name of a Numeric Field 



Object that contains the value "$100.00" - and <<TaxPercentage>> is a Numeric Field 
Object that contains the value ".07" - the Formula Field Object where this formula is 
entered will display "$7.00".    

$100.00 times .07 equals $7.00.

You could also enter the above formula as:

<<Total>> x .07

Another example of a formula entered in a Formula Field Object:

<<Sum1>> + <<Sum2>> + <<Sum3>> + <<Sum4>> x .07

Calculation takes place sequentially. <<Sum1>> is add add to <<Sum2>>; the result is 
added to <<Sum3>>; THAT result is added to <<Sum4>>; then that value is multiplied 
by .07.

Remember that formulas from Formula Field Objects are figured sequentially ACCORDING 
TO THE TAB ORDER you set for each Object in the Field Description Window...    Be careful 
that you don't refer to a Field value that comes AFTER the Formula Field you are editing.

Conditional Formulas

Examples of Conditional Formulas displayed in Formula Field Objects:

If <<InterestType>> = "High Rate" Display <<Principle>> * .14
If <<InterestType>> = "Medium Rate" Display <<Principle>> * .11
If <<InterestType>> = "Low" Display <<Principle>> * .08

In the above example there are three Conditional Formulas.    The FIRST Formula that is 
TRUE in any given Record will be the one whose "Display" parameters are used by 
ViaBase.    Any Conditional Formulas following the first TRUE Formula will be ignored.

You can use references to other Field Objects besides Numeric ones in formulas.    Another 
example:

If <<DateDuesPaid>> < 1/1/1994 Display "Membership Expired"

In this example <<DateDuesPaid>> is the name of a Date Field Object.    If the date stored
there is less than 1/1/1994 the Formula Field Object will display the text "Membership 
Expired".

Notes On Formula Field Objects

Important Note:    When you change the formula for an existing database BE SURE to select
"Re-Calculate Formula Fields" from the Edit Menu... This action will update all Formula 
Fields in the entire database.    OTHERWISE Formula Fields are only calculated when the 
each record is displayed.    Thus the Query or Search Functions will not be accurate 
because any records that have not been displayed since the formula change will still hold 
the results of the original formula.

If a Character Field Object... is referred to in a formula, and the Character Field contains a 



numeric value, it will be trreated as a number in the calculation of the formula.    This only 
applies to unformatted numbers. Numbers that contain "$" are treated as alphanumeric.

You can format the way a formula calculation is displayed if it is numeric.    Use the "Field 
Format" Option from the Field Menu...



Ordering Information...
ViaBase is Shareware.

The Shareware version of ViaBase may be evaluated for a period of 45 days, if you 
continue to use the program after that initial evaluation period, you must purchase the 
commercial version.    For Site Licenses and Multiple purchases see below.

IMPORTANT NOTE ON LIMITATIONS

With the shareware version of ViaBase, after your 45 day evaluation period has expired 
two changes will take place:

1.    A Timed Reminder Window will appear every time you use any of ViaBase's major 
functions. 

2.    You will no longer be able to add Records.    You can still save, load, and export as ascii, 
however.

 Upon ordering we'll give you a code that will turn off the Reminder Window and allow 
additional Records.

Ordering ViaBase v1.4
To purchase the commercial version send $49.95 ($44.95 + $5.00 shipping and handling).  
For your fee you will receive the following:

- The latest version of    ViaBase.

- As a registered User of ViaBase, you will be able to purchase ViaPrint Ultra... 
v3.0, Viable's new multi-purpose Labeling Utility that is integrated with ViaBase,
for HALF PRICE: $17.25 instead of the normal price of $34.50.    A Shareware 
version of ViaPrint will be included on your ViaBase disk.

- Notification of updates.    ViaBase will be updated with new features and 
conveniences (and bug fixes) regularly.    Registration will insure that you 
receive notification of, and significant discounts on, all future updates.

- Technical Support by Telephone.    (We cannot offer phone technical support for
the Shareware Version, but you are welcome to write us with any problems...)



- A printed ViaBase Manual.

Please Order Soon!
CompuServe Members: GO SWREG, Product #4683

In The U.S., Mexico, Canada, Central and South America, Africa, 
and Asia:

Send ONLY $49.95 for each copy needed (Site Licences are available: $40.00 each for 
quantities from 2 to 5; $35.00 each - 5 to 15 copies; $25.00 each - over 15 copies) to:

Viable Software Alternatives
PO Box 98134
Las Vegas, NV      89193-8134
USA

Or Call:

1-800-854-4902 with your MasterCard or VISA number.
                          (ORDERS ONLY, please.    For Site Licensing info or other questions call 618-
549-5227.    Please do not use this 618 number for support calls regarding the SHAREWARE
version.    Support on shareware versions is offered by mail only.)

Add $17.25 to take advantage of the ViaPrint Ultra... offer!!

In Europe and the UK

ViaBase: £34.95 
VAT (@17.5%):     £6.12
Shipping:     £3.00

----------
Send:  £44.07    for each copy needed to:

The Thompson Partnership
Lion Buildings
Market Place
Uttoxeter, Staffs
ST14 5DE
UK

        Or Call:

                    Phone +44 (0) 1889 564601
Fax          +44 (0) 1889 563219
BBS        +44 (0) 1889 568625
(MasterCard, Visa, American Express, Diner's Club)



Add £11.69    (£9.95 + VAT £1.74) to take advantage of the ViaPrint Ultra... offer!!

Total (ViaBase and ViaPrint): £55.76

In Australia and New Zealand:

Send ONLY $59.00 for each copy needed to:

BUDGETWARE
PO Box 496
Newtown NSW 2042
Australia

Or Call:

Phone      (02)519-4233
Fax              (02)516-4236

 (Cheque, Money order, Bankcard, MasterCard, and Visa)

In Japan:

Contact for local registration.

P. & A. Shareware
302 Bellwins, 1367-23
Nakagami, Akishima
Tokyo, 196 Japan

            Or Call:

Phone        0425-46-9141
Fax                0425-46-9142
Nifty              PAF02461
(Credit Cards, on Nifty, by bank and/or postal transfer, COD, etc...)

Thanks For Trying ViaBase!



Adding List Items To A List Object
[Available Only In DATABASE MODE From List Objects]

The List Field... and the Data List Field... display an additional command button when you 
are in Database Mode... as shown below:

The "Add" Button allows you to add to a list, and displays the following window:

The Add To Field List Window

To add list items:    Enter the item you wish to add in the "Item To Add" text box.    When 
you've typed it like you want it, click on the "Add" Button (or hit Enter on the keyboard) 
and that item will be added to the list.

To delete a list item, click on the item so it is highlighted, then click on the Delete Button.

You can also copy an entire list here and then paste it into another List Field Object.

When you click on "Close" the Window will disappear and the edited list will take effect.



Each piece of information in your database Record is a FIELD. For example, in the following
mailing address database:

Casey Butler [Name Field]
P.O. Box 98134 [Address Field]
Las Vegas [City Field]
NV [State Field]
89193 [Zip Field]

ALL of the above fields put together make up one Record in this particular database.



Field Objects are made up of two parts:    The Field and the Prompt.    The Prompt is the part
of the Field Object that you use to "drag" the Object to a new location.    Normally the text 
you type in the Prompt is used to explain what the Field should contain.    See "Field 
Object" under Field Types... for more information on Prompts.



The ViaBase Query Record
[The Query Record Is Available In DATABASE MODE]

The ViaBase Query capability allows you to select, Save, browse, or print only those 
Records that match the criteria you set up in the Query Record.

To edit the Query Record and set your criteria, choose the "Edit The Query Record" option 
from the View Menu... The ViaBase Toolbar will change to the following:

What the Query Toolbar Icons do:

Clicking this button returns you to your ViaBase database Records.    If you ran a Query, 
only those Records that matched your Query will be shown.    See also: View Menu... "Exit 
Query Record".

APPLY the Query Record.    This causes ViaBase to check each Record in the database 
against the data in the Query Record, noting only those Record that match.    See also: 
View Menu... "Apply Query".

Displays the Query History Window...      See also: View Menu... "Query History".

Completely CLEARS the Query Record, removing all Conditions and data from the Query 
Fields.      See also: View Menu... "Clear Current Query".

Displays the Query Conditions Window (see below).      See also: View Menu... "Edit Query 
Field Conditions".

The Query Record itself looks just like your Database Design Template, with the same Field 
Objects and Design Objects.

Running A Simple Query

The Simple Query is easy to understand.    You just enter the text that you want the Query 
to match, and enter it in the Field Object where you want it searched for.    Then click on 
the Apply Query Button or select "Apply Query" from the View Menu...



For example, say your database is made up of a list of company employees that consists 
of:

LastName [Character Field Object]
FirstName [Character Field Object]
Address [Character Field Object]
City [Character Field Object]
State [Character Field Object]
ZipCode [Character Field Object]
Status [List Field Object]

The "Status" List Field Object contains the following list:

"Sales Department"
"Marketing Department"
"Shipping Department"
"Customer Service Department"

In the Query Record, you type "Smith" in the Query <LastName> Field Object, then select 
"Shipping Department" from the <Status> Field Object's list.

You then Apply the Query - ViaBase will search through all of the database Records, 
matching only those Shipping Department employees whose last name is Smith.

When the Query is complete, the number of matches found is displayed on the Toolbar.    If 
you Exit the Query Record at this point, ONLY the Records that match the Query will be 
shown. (Select "Clear Current Query" from the View Menu... to see the entire database 
again)

When you return to the Query Record your criteria entries will be intact for further 
Querying.

Running A Conditional Query

Sometimes you need more than simple field matches to locate a group of Records with the
Query.

In that case, first click on the Field Object you want to Query, then select "Edit Query Field 
Conditions" from the View Menu... and the Query Conditions Window will appear:

You can set up to three Conditions that the ViaBase Query will follow in determining 



whether the contents a field will be a "match" or not.

Eight conditions are available and are accessed by clicking on the conditional list box 
(which defaults to "Don't Use").    The conditions you can select    are: "Equals", "Doesn't 
Equal", "Is Greater Than", "Is Less Than", "Contains", "Doesn't Contain", "Is Blank", and "Is 
Not Blank".

After selecting the Condition, enter the text that must be tested for that Condition in the 
text box to the right of the conditional list box.    This is the text that must pass the 
Condition within the database record if that record is to become a Query matched record.

The varying Conditions and their effects are listed below:

Equals: The database field must exactly match the text you entered to the right of 
the conditional list box (the comparison ignores case).

Doesn't Equal: The field must be different from the text you entered.

Is Greater Than: The field must be greater than the text you entered. 

NOTE: The field will first be converted to its intended Field Object Type (ie. Numeric, Date, 
etc...) before the comparison is made.

Is Less Than: The database Record field must be less than the text you entered.    
See Note above.

Contains: The field will be scanned tor the text you've entered.    If the text is found 
anywhere within the field, the record will be matched.    For example, if the field you are 
conditionalizing contains the text"1/5/93" and you enter "93" as the conditional text, the 
Record will be matched.

Doesn't Contain: The field will be scanned tor the text you've entered, but the 
Record will be matched only if the text was not found.

Is Blank: The record will only be matched if the field is blank.

Is Not Blank: The record will only be matched if the field is not blank.

Between the three Conditions allowed in the Query Conditions Window are command 
buttons that change from "And" to "Or" and back to "And" again.    These give you greater 
flexibility in conditionalizing your Query.

For example, if you set your Conditions to read...

Match Record If:
    LastName      Equals      Smith

Or If:    LastName      Equals Jones

And If: DateHired     Is Less Than        1/1/93

ViaBase will match all records of anyone named Smith or Jones that was hired before 
January 1, 1993.

Notes On Queries



Remember, you can set three Conditions on EACH Field Object that you create, so 
Querying can be a very powerful tool for locating Records in a large database.



The Browse Bar (Database Mode Only) allows you to change Records forward or backward 
through the database.    Clicking on the left or right arrows will move forward or backward 
one Record at a time.    Clicking on the Bar itself will move 15 Records at a time. 

You can also change Records through the Keyboard, see Keyboard Controls...



A Step-By-Step Walkthrough
Things To Decide Ahead Of Time

1. Decide what type of information you'll be storing in your new database.    For this 
example, we'll create a simple NAME, ADDRESS, and BIRTHDATE database.

1. Decide how many items for each RECORD    . Each item requires a FIELD.    For this 
example database, we'll use SIX fields: enough to record a Name, an Address, a City, a 
State, a Zip Code, and a field for the Birthdate.

2. Decide the order of the fields and their arrangement on the screen. Use a paper and 
pencil to design the look of your ViaBase Template.    We'll just put the Field Objects one 
under another for this sample.    We'll keep the order as we listed the fields above: Name, 
Address, City, State, Zip Code, and Birthdate.

Design your Template

1. From the File Menu... select "New"..

2. From the Design Menu..., select "Background Screen", and choose    the color you want 
for your Template background. 

3. There is a single Field Object... on the Template.    Position your mouse cursor within the 
area where you see the words "Blank Prompt".    Press and hold down the left mouse button
and drag the Field Object down an inch or so - and about a half an inch over to the right.    

4. Now is a good time to select the colors you want your Field Object displayed in.    See 
the Design Menu... for assigning colors to Objects.    You can change this Field Object's 
Prompt color, Text color, and Background color.    When you add another Field Object, it will 
be set to the same colors as the last one you added.

5. Expand the width of the Field Object.    Put the mouse cursor over the little blue resizing 
tab at the far right of the Object (The tab is out there all on its own!).    The mouse cursor 
will change to "<-->" when you are over the tab. Press the left mouse button and, while 
holding it down, "drag" the resizing tab about an inch farther to the right than it already is.

6. Add another Field Object:    Select "Add Field" from the Design Menu.    The new Field 
Object will appear in the upper left-hand corner of your Template.    It will be the same 
color and width as the object you already positioned.

7. Drag this Field Object directly below the first.

8. Add FOUR more Field Objects by selecting "Add Field" from the Design Menu, or you can 
click on the (+) Toolbar... icon.    Drag them down under the first also.

9. If you are having trouble lining the Field Objects up properly, select "Snap To Grid" from 
the Design Menu...    That helps!



Your Template should now look like:

Okay so far?

10. Select the FIRST Field Object by clicking once on the Prompt part (the part that says 
"Blank Prompt").    You will see the Prompt text displayed in the Edit Box... and the Prompt 
and Field parts of the Field Object will be highlit by blue resizing tabs.    Now type the word 
"Name:" in the Edit Box. CONTINUE typing SPACES after the word "Name:" until the Field 
Part of the Object lines up with those underneath.

11. Select the SECOND Field Object - click once on the Prompt part, remember - and enter 
"Address:" in the Edit Box.    You'll see the second Object's Prompt change as you type.    
Once again continue beyond the word "Address:", typing only spaces in order to line the 
Field Object up with the rest.

12. Using the same steps, enter "City:" as the third Field Object's Prompt, "State:" for the 
fourth, "Zip Code:" for the fifth, and "Birthdate:" for the sixth!    Make sure they all line up 
neatly...

13. Once again, select the FIRST Field Object (the one whose Field part says "Field1: 
Character"), and from the Field Menu... select "Field Settings".    The Field Desciption 
Window... will appear (you can also double-click on the Prompt part to access this window).

14. From this window we learn that the NAME of the first Field Object is "Field1", its TAB 
ORDER is "1", and it is a CHARACTER Type Field.    Let's give the Field Object a more 
meaningful name.    Type "Name" in the NAME text box, then click on the "Okay" Button.    
You'll see that the Field part of the first Field Object now reads "Name: Character".

15. Using the same process, give each of the next FOUR Field Objects the names 
"Address", "City", "State", and "ZipCode" (Note there are no spaces in the Field Object 
Name "ZipCode").



16. Now select the SIXTH Field Object (the one whose Field part still says "Field6: 
Character").    From the Field Menu... select "Field Settings".    The Field Desciption 
Window... will appear again.

17.    Give the sixth Field Object the name "Birthdate" - but don't click on "Okay" yet!    
Since we will be using this Field Object to hold a DATE, click on the option button that says 
"Date Field".    Now click "Okay" on the Field Description Window.    The Field part of the 
sixth Field Object now reads "Birthdate: Date".

18. With the sixth Field Object still selected, choose "Field Format" from the Field Menu... 
and choose the format [January 1, 1995].

19. One more step to make the Template look good.    Let's draw a Box Object... around our
Field Objects.    Move the mouse cursor to just above and a little to the left of the first Field 
Object, the one named "Name".    Make sure the mouse cursor is shaped as a pointer and 
not an up-arrow.    If it is an up-arrow move it a little further away, up and left, from the 
Field Object (an up-arrow mouse cursor means you are already over another object rather 
than over the Template itself).    Press the left mouse button, and, while holding it down, 
drag the mouse cursor down and to the right.    You'll see a box being drawn as you pull.    
Keep pulling until the box completely surrounds the six Field Objects.

20. Release the left mouse button and select "Draw Box" from the Design Menu...    A Box 
Object appears!    You can change the color of the Box Object by selecting "Label, Picture, 
and Prompt Color" from the Design Menu.    Make sure your Box Object is "selected" first.

That's it!    You've created a ViaBase Database!    Select "Lock Design" from the Edit Menu...
or click once on the Lock Control...

Editing Your Database

As soon as you lock your design, your database is ready to edit.

1.    Enter "John Smith" in the Name Field.

2.    Press [Tab] and enter "3 Willow Lane" in the Address Field.

3.    Press [Tab] and enter "Cleveland" in the City Field.

4.    Press [Tab] and enter "OH" in the State Field.

5.    Press [Tab] and enter "33333" in the ZipCode Field.

6.    Press [Tab] and enter "3/3/1933" in the Birthdate Field. When you leave the Birthdate 
Field your date will be formatted as "March 3, 1933".

You now have:



7.    Select "Add Record" from the Edit Menu... or just press the (+) Toolbar Icon.

8.    Put something in the second record!!!

You're on your own!    I hope ViaBase proves helpfull to you!



The Query History Window
[History Available Only In DATABASE MODE]

Every time you run a Query..., a "history" on that Query is kept.    To view the Query History
Window, select "View Query History" from the View Menu...

The Query History records the information on all fields involved in the Query, whether 
Simple or Conditional.

You can keep totals on queried Numeric Field Objects by setting that Object as a "Total 
Field" in the Total Menu.    The Total will be displayed in the History the same way the 
Object was formatted in Design Mode...

In addition, when you set a Total Field a "Grand Total" will be kept added up for each Query
and added onto the bottom of the Query History.    You can choose a format for the "Grand 
Total" using the Total Menu.

Histories can be printed, saved, and reloaded, and you can copy their contents for pasting 
into other applications.

To clear an old History and start a new one, select "New History" from the History 
Window's File Menu.



Exporting Your Database As Text
Selecting The File Type To Save

Selecting the "Export As Ascii" option from the File Menu... will display a File Window with 
the following controls on its right-hand side:

Saving a Comma-Delimited File

You can save your ViaBase Records in two Ascii Formats:    Comma-Delimited Ascii... and 
Label Ready Ascii.

If you click on the "Comma Delim." Button the command button below it will read "Select 
Fields".    Click on this button and a window appears in which you can choose which fields 
you'll save in the Ascii file and in which ORDER they'll be saved.

After choosing the fields, enter a file name in the File Window, click on "Okay", and the 
Records will be saved under the file name you specified.

Saving a Label Ready File

When you click on the "Label Ascii" Option, the button below it will change to "Design".    
Click on that button and    a window will appear in which you can design the layout of the 
text file you wish to create.    Look at the following example:



The above Label Ready design will produce the following formated Records in the file when
saved:

Sam Jones
ACME Products
24 Willow Street
Austin, TX      39292

Department: Shipping
Date Hired: 01/01/1995

When each Record is written to the file, blank field lines are removed but another is added 
at the end of the Record to fill the gap.    Label Ready files can be loaded into Windows 
Notepad and printed.



Comma-Delimited Ascii database files contain Records in the following format:

"Name", "Address", "City", "State", "ZipCode" [Carriage Return]

RECORDS are separated by Carriage Returns, while FIELDS are separated by commas.    
Note that fields are also contained within double quote marks.    This allows a program to 
tell which commas separate fields and which commas are PART of the field text.



Moving A Group Of Objects
To move a group of Design Objects in ViaBase you first need to draw a box around all of 
the Field Objects, Picture Objects, Label Objects, and Box Objects that you want to move.

Place the mouse cursor over the point where you want the upper left corner of the box to 
be.    The mouse cursor MUST be in the shape of a "mouse pointer" (not up-arrow)    - if it 
isn't, that means you're on top of a Field Object, Picture Object, Label Object, or Box Object
already.

Now press the left mouse button and, holding it down, drag the mouse cursor down and to 
the right, including all of the objects to be moved within your box.    As you do this a blue 
box outline will appear on the Template.    Now release the mouse button.

A Move Box will appear around your selected Objects.

Moving:    To move the selected objects, move the mouse cursor onto the center of this 
Move Box and drag it to the new position.    All Field Objects, Picture Objects, Label Objects,
and Box Objects within will be repositioned.    You can continue repositioning until you're 
happy with the results.    When that happens, just click anywhere on the Template OTHER 
than over the Move Box to end the move operation.



ViaPrint Ultra
Print your Database Records In Style!

This Mailing Label was created in ViaPrint!

ViaPrint Ultra is the ultimate companion program for ViaBase!    ViaPrint's BUILT IN 
Database Viewer will give you all the querying power of ViaBase to create custom 
printouts of ALL kinds.

 ANY database you create in ViaBase will be beautifully recreated on paper through 
ViaPrint!



Use ViaPrint For:

- Mailing Labels
- ViaBase Reports
- Flyers
- Business Cards
- Cassette Tape Labels
- Video Tape Labels
- More!    Your imagination is your ViaPrint's only limit.

ViaPrint Features:

* Full compatibility with your ViaBase Databases!

* Import your favorite Pictures.    Add up to 10 .BMP (Windows Bitmap) or .WMF (Windows 
Metafile) pictures to your label or flyer.

* Print MAILING Labels using ViaPrint's Database Printing Capability! "Comma-Delimited 
ASCII" format, dBASE IV format, and the new ViaBase format are supported.

* Text Rotation!.    Rotate your text to any angle for attention grabbing headlines or tiny 
copyright notices.

* "Drag and Drop" text, box, and picture placement.

* Line Box and Picture Resizing.    Stretch your pictures and boxes to the size you need 
using your mouse.

* Easy to use, up front controls.    Make use of all your True Type fonts.



* Built in Font Viewer and Character Selector.    Use your "WingDing" or "DingBat" fonts for 
interest effects.

* COLOR capability.    Use colored fonts and boxes for special effects.    Pictures are printed 
in COLOR.    (You must have a color printer, of course!)

SPECIAL OFFER!

If you order ViaPrint Ultra with ViaBase, you'll get ViaPrint at ONE HALF PRICE!    Only 
$17.95!    See Ordering Information... for more.



Warranty, Licensing...

ViaBase is a copyrighted, proprietary program offered "as is", without any warranty of 
merchantability or fitness for a particular purpose, performance, or otherwise; all 
warranties are expressly disclaimed.    By using ViaBase, you agree that the author will not 
be liable for any use of (or inability to use) or performance of this product, or for any 
damages whatsoever.

The registered version of ViaBase may be used on only one machine at any one time.    Site
Licenses are available for multiple copies - See "Ordering Information...".

This software is being distributed as Shareware.      You may use this program freely for 
forty-five (45) days.    If you wish to use it for longer than forty-five days, you are required 
to register it with the author for $49.95 US.    You may also copy and distribute this 
SHAREWARE VERSION of this program, as long as all the files are distributed intact in a 
single archived file - and the conditions in the accompanying VENDOR.DOC are adhered to.
You may not sell this program, and you may charge only nominal fee for distribution not 
exceeding $8.00 a copy.






